DLNA/UPnP is a mess

I posted recently about how I'd been playing with Snakeoil OS, but had come to a dead halt because I haven't the required level of tinfoil helmet to set it up.
What made me try Snakeoil OS was a creeping dissatisfaction with Volumio's SQ. At least, I had become convinced that the soundstage had lost its height and there was a graininess that wasn't there before.
In the past, I'd always preferred MoOde, but for reasons I didn't fully understand at the time, and have long since become victim to uglymusic bit rot, I think it was version 5 that needed compilation from source code. This proved beyond my abilities - see tinfoil helmet level, above. Anyway, MoOde has stopped that stupidity - I suppose Tim ended up with no users or a ginormous support load - so I installed MoOde.
Oh, it sounded great. The soundstage has height and depth and width and there is a round rightness about the tonality. I hadn't been imagining that Volumio's SQ had gone off the boil.
But, suddenly the Linn app on my iPhone lost contact with MoOde - of course, MoOde carried on playing because that's the way DLNA works, with no music going via the phone (control point) - and no amount of rebooting and tweaking at the MoOde end could get the Linn app to maintain or sometimes even establish contact.
I tried Linn Kazoo and the Lumin app, and neither would work reliably. Not really a surprise because neither was working properly with Volumio. And even the Linn/Volumio combo had a nasty habit of leaping to 100% volume at the start of the listening session. I'd blamed Volumio for this, but now I'm not so sure.
The latest versions of the DLNA apps all have features for use with the manufacturers' own hardware. From my recent experience, it looks like you can't use them to control plain vanilla UPnP devices like my RPi/MPD-type setup. I've been stopped from piggy-backing on Linn and Lumin's app development. Thanks, guys!
I've mentioned before on Chews that I thought I could find myself without a viable control app as the only ones I could find for iOS were from hifi manufacturers, produced for their own customers, so this isn't a surprise. It was always likely to go this way.
There is - so I'm told - a good Android control app in the shape of Bubble UPnP. But I don't want to buy an Android device just to run it.
So I'm now in the process of jumping ecosystem to LMS. I have the server running on my Syno and will hopefully get a chance to get piCorePlayer up on the RPi.

A lot of the above is my surmising and a bit of Googling. If anyone knows some facts I haven't picked up on or has another view, I'd  welcome them.

Comments

  • Hi mate

    I'm really sorry that I've got nothing that'll help. As you'll be aware, my patience for this audio computer nonsense is rather shorter than yours, as are my abilities. 

    I occasionally have to muck about, but not much. I re-commend Bubble to you , perhaps utilising a second hand tablet or cheapie smartphone running Android. Used purely as a HIFI smart-remote control, eighty smackers or so might make sense. And, if the Android cooties do get to you, you'll be able to resell it for what you paid.

    I, too, once sullied myself thusly; I bought a mk 1 iPad for exactly the same purpose. However it's utterly useless because apple reasons (it's older than six months) so it's on a shelf somewhere. It probably wouldn't even boot now.

    In general, I've no issue with DLNA. I don't feel driven to particular manufacturers or proprietary software either. I hope you get something sorted out. 😊
  • I'm now sorted - see other threads - Alan. But thanks for your thoughts and concern.
  • I'm with Alan on this one, although an Android user already I have a second mobile purely for music duties and its wide angle camera. It has never made or received a phone call :D
  • edited June 3
    I used to have an Android tablet and didn’t get on with it :-(

    It’s one reason why I didn’t go down that route. 

  • Maybe I was being a little provocative with the title ;)
    DLNA/UPnP is in a mess for iOS users who aren't a customer of a major hifi company just doesn't have the ring, somehow :)
  • I used to use run a separate mini dlna server until I Got my current set up, an allo usbridge signature player running Volumio. Now I just plug an ssd into that, stream straight from it. I have an iPhone and it’s terrible with anything not apple related tbh, including my Roku tv. Vlc does an ok job of streaming on a iPhone from a dlna server but roon it ain’t.
  • Interesting you had similar problems and fled to another solution.
    I tried a couple of DLNA iOS apps, but they weren't UPnP and felt like something from the 20th Century :-)
    I have wondered if plugging straight into the RPi might give better SQ, but it's not really going to work here. For a start, I have approaching 2TB of music files. Then, I share the music throughout the house - the bedroom system 2, 2 x Sonos in my office, a Sonos in the kitchen and Roberts radio with RPi Zero innards a friend built for me that gets used in the bathroom and garden. I'm thinking of doing a similar thing with an 80s/90s ghetto blaster to make more noise outside.
    And I don't really want to lose the resilience that RAID gives me in the Syno.
    I have thought of building an audio-only NAS drive, just running the software I need for music, leaving the Syno for work, photography and music. An 8Gig RPi 4 is tempting used with some spare USB drives configured in RAID. In theory, I could run piCorePlayer with LMS, Bliss and NAS software.
    But HB says the RPi 4 is not a good sounding as the 3 :-(
    Maybe I'll just build the RPi 4 NAS for fun, anyway.

Sign In or Register to comment.