Inca Tech Claymore Mods and Repair Thread

13»

Comments

  • Fried? You sure?
  • edited August 1
    Hope this works, found a real photograph, you know, the glossy paper ones, of my original Claymore, purchased errrrrrrm, a while ago! I believe it was early on for an ISS6.
    My new turntable was on order (Mantra).


    Claymore https://imgur.com/gallery/PvJYlde


  • Oh well :(

    Dave, how to post pics here via mobile?
  • I'm not sure how it works from Imgur. It doesn't seem to offer a usable URL, so I'll have to look into it.
  • I don't know if you can do this on mobile but I right-clicked on the image and copied it. Then I clicked on the picture icon above and pasted in the photo.
  • Just posted that from my iPhone. BUT I had to click the “full site” option at the bottom of the page before hand to gain access to the image icon (it’s not present on the “mobile view” default format).
  • edited August 4
    I have the image icon via android but it doesn't work. Pop the image url in the box and......it disappears.
    Haven't tried full site...now have, still have disappearing url box.
    I have posted pics in the past from a PC but never succeeded from android.

    It's a mysthterwee, oh it's a mysthterwee, a shot in the dark.....
  • Chews is nothing if not mercurial.
    On my iPhone the image posting works only if I press the “Go” button on the pop-up keyboard, and not the “Done” button. Can’t remember there being another situation where there’s a functional difference between those two.
  • Oh poop! 
  • Hi,
    I've had a Claymore since 1987 working really well without a fault until yesterday when I suddenly lost the left channel for all inputs. I would have suspected the output fuses except that if I only feed input to the left channel then I can still hear the faintest sound from the system.
    Does any body have a good idea on where to start looking for the problem?
    How long should I leave the amp unplugged before opening the box?
  • JCB,

    The signal can still get across the fuse due to capacitance is it thin low level if so the chances are are a dud fuse. 
  • It could also be a s/c on the mini balance and or the volume pot.

  • Thanks, I'll take the cover off and check the fuses.

    Any idea how long I should wait to let the caps discharge before touching anything inside?

    Are the fuses easy to buy these days?
  • One fuse was blown.
    Got a couple of fuses at my local computer repair shop, fitted them and now amp works like new.

    Thanks for the help.

  • JCB about 30secs, well done enjoy best Col
Sign In or Register to comment.